Search has encountered a problem that prevents results from being returned

I got the following error in search results:

Fehlermeldung1

When looking into the Log-Files I found the following:

07/02/2015 13:17:56.99                w3wp.exe (0x6B58)                                      0x35AC SharePoint Server Search          Query                                         dka5      High      SearchServiceApplicationProxy::Execute--Error occured: System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: Tried IMS endpoints for operation Execute: Cannot plan query for index system SP687d6eeb0241. Index fragment '0' has no available cells. Cell statuses: [Cell I.0.0 on node IndexComponent1: Cell status is set to 'not available' (cell out of sync or seeding)] (Fault Detail is equal to An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is: Microsoft.SharePoint.SPException: Tried IMS endpoints for operation Execute: Cannot plan query for index system SP687d6eeb0241. Index fragment '0' has no available cells. Cell statuses: [Cell I.0.0 on node IndexComponent1: Cell status is set to 'not available' (cell out of sync or seeding)]   ... 990a169d-5bdf-904e-2a6f-03276c7b13e1

Here is how to fix this issue:

1. Stop the SharePoint Timer Service (Server Manager > Tools > Services)

Fehlermeldung3

2. Clear the SharePoint configuration cache. Therefore navigate to \ProgramData\Microsoft\SharePoint\Config and find the folder that contains the file cache.ini.

Fehlermeldung2

Delete all files in that folder, except the cache.ini. Afterwards open cache.ino in notepad an replace the content with a simple 1. Save the file.

Fehlermeldung4

3. Restart the SharePoint Timer Service (Server Manager > Tools > Services)

4. Do an index reset in Central Administration (Manage Service Applications > Search Service Application > Crawling > Index Reset)

5. Do a full crawl (Manage Service Applications > Search Service Application > Crawling > Content Sources)

Afterwards your search results should work as expected.

Leave a Reply

Your email address will not be published. Required fields are marked *